#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}"
Local $sString = "bhargavi.bommidi@gmail.com" & @CRLF & _
"lovely.bhar@rasna" & @CRLF & _
"rasna_bha@phb.in" & @CRLF & _
"^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")