import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}";
final String string = "bhargavi.bommidi@gmail.com\n"
+ "lovely.bhar@rasna\n"
+ "rasna_bha@phb.in\n"
+ "^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}