use strict;
my $str = 'bhargavi.bommidi@gmail.com
lovely.bhar@rasna
rasna_bha@phb.in
^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}
';
my $regex = qr/^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}