package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@][a-z][a-z0-9]{2,9}[.][a-z]{1,3}`)
var str = `bhargavi.bommidi@gmail.com
lovely.bhar@rasna
rasna_bha@phb.in
^[a-zA-Z][a-zA-Z0-9_.]{5,20}[a-zA-Z0-9][@]^[a-z][a-z0-9]{2,9}[.]^[a-z]{1,3}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}