import Foundation
let pattern = #"[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
10 mg/day
10 mg per kg
10 mg/d
10 mg/kg/day
10 mcg
10 units
10 mg BID
10 mg/day
0.075% Lotion
5%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)