import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9]{1,4}[ ]{0,1}(mg)[\\/]{0,1}(kg\\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]";
final String string = "10 mg/day\n"
+ "10 mg per kg\n"
+ "10 mg/d\n"
+ "10 mg/kg/day\n"
+ "10 mcg\n"
+ "10 units\n"
+ "10 mg BID\n"
+ "10 mg/day\n"
+ "0.075% Lotion\n"
+ "5%\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}