#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]"
Local $sString = "10 mg/day" & @CRLF & _
"10 mg per kg" & @CRLF & _
"10 mg/d" & @CRLF & _
"10 mg/kg/day" & @CRLF & _
"10 mcg" & @CRLF & _
"10 units" & @CRLF & _
"10 mg BID" & @CRLF & _
"10 mg/day" & @CRLF & _
"0.075% Lotion" & @CRLF & _
"5%" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")