$re = '/[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]/m';
$str = '10 mg/day
10 mg per kg
10 mg/d
10 mg/kg/day
10 mcg
10 units
10 mg BID
10 mg/day
0.075% Lotion
5%
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);