package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[0-9]{1,4}[ ]{0,1}(mg)[\/]{0,1}(kg\/day|kg|day|d)|[0-9][ ]{0,1}(mcg|units|BID)|([0-9][0-9.]){0,1}[0-9]{1,3}[%]`)
var str = `10 mg/day
10 mg per kg
10 mg/d
10 mg/kg/day
10 mcg
10 units
10 mg BID
10 mg/day
0.075% Lotion
5%
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}