re = /\S.+CONTRIBUTE A TEST\r?$/m
str = '- T1566.002 Spearphishing Link CONTRIBUTE A TEST
- T1566.003 Spearphishing via Service CONTRIBUTE A TEST
- T1195 Supply Chain Compromise CONTRIBUTE A TEST
- T1199 Trusted Relationship CONTRIBUTE A TEST
- T1078 Valid Accounts CONTRIBUTE A TEST'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end