const regex = /\S.+CONTRIBUTE A TEST\r?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\S.+CONTRIBUTE A TEST\\r?$', 'gm')
const str = `- T1566.002 Spearphishing Link CONTRIBUTE A TEST
- T1566.003 Spearphishing via Service CONTRIBUTE A TEST
- T1195 Supply Chain Compromise CONTRIBUTE A TEST
- T1199 Trusted Relationship CONTRIBUTE A TEST
- T1078 Valid Accounts CONTRIBUTE A TEST`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}