$re = '/\S.+CONTRIBUTE A TEST\r?$/m';
$str = '- T1566.002 Spearphishing Link CONTRIBUTE A TEST
- T1566.003 Spearphishing via Service CONTRIBUTE A TEST
- T1195 Supply Chain Compromise CONTRIBUTE A TEST
- T1199 Trusted Relationship CONTRIBUTE A TEST
- T1078 Valid Accounts CONTRIBUTE A TEST';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);