#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\S.+CONTRIBUTE A TEST\r?$"
Local $sString = "- T1566.002 Spearphishing Link CONTRIBUTE A TEST" & @CRLF & _
"- T1566.003 Spearphishing via Service CONTRIBUTE A TEST" & @CRLF & _
"- T1195 Supply Chain Compromise CONTRIBUTE A TEST" & @CRLF & _
"- T1199 Trusted Relationship CONTRIBUTE A TEST" & @CRLF & _
"- T1078 Valid Accounts CONTRIBUTE A TEST"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")