import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\S.+CONTRIBUTE A TEST\\r?$";
final String string = "- T1566.002 Spearphishing Link CONTRIBUTE A TEST\n"
+ "- T1566.003 Spearphishing via Service CONTRIBUTE A TEST\n"
+ "- T1195 Supply Chain Compromise CONTRIBUTE A TEST\n"
+ "- T1199 Trusted Relationship CONTRIBUTE A TEST\n"
+ "- T1078 Valid Accounts CONTRIBUTE A TEST";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}