import Foundation
let pattern = #"^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
# Valid
victor.schroeder@35up.com
victor.schroeder+foo@35up.com
v_s@35up.com
1233@35up.com
victor.schroeder@xn--bcher-kva.de
# Invalid
victor.schroeder@35up
victor.schroeder@.35up.com
victor.schroeder@35up.com.
victor.schroeder@-35up.com
victor.schroeder@35up-.com
victor.schroeder@35up.com-
victor.schroeder@35up.-com
victor.schroeder.@35up.com
victor.schroeder@35up..com
.victor.schroeder@35up.com
victor.schroeder@35--up.com
victor.schroeder@xn---bcher-kva.de
victor.schroeder@35_up.com
# Blacklisted chars
victor;schroeder@35up.com
victor,schroeder@35up.com
victor@schroeder@35up.com
victor[schroeder@35up.com
victor]schroeder@35up.com
victor(schroeder@35up.com
victor)schroeder@35up.com
victor<schroeder@35up.com
victor>schroeder@35up.com
victor:schroeder@35up.com
victor schroeder@35up.com
victor\schroeder@35up.com
victor"schroeder@35up.com
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)