const regex = /^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$/img;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\.)(?:\\.?[\\w\\+]++)++@(?!\\.)(?:\\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\\-]++(?<!-)){2,}$', 'img')
const str = `# Valid
victor.schroeder@35up.com
victor.schroeder+foo@35up.com
v_s@35up.com
1233@35up.com
victor.schroeder@xn--bcher-kva.de
# Invalid
victor.schroeder@35up
victor.schroeder@.35up.com
victor.schroeder@35up.com.
victor.schroeder@-35up.com
victor.schroeder@35up-.com
victor.schroeder@35up.com-
victor.schroeder@35up.-com
victor.schroeder.@35up.com
victor.schroeder@35up..com
.victor.schroeder@35up.com
victor.schroeder@35--up.com
victor.schroeder@xn---bcher-kva.de
victor.schroeder@35_up.com
# Blacklisted chars
victor;schroeder@35up.com
victor,schroeder@35up.com
victor@schroeder@35up.com
victor[schroeder@35up.com
victor]schroeder@35up.com
victor(schroeder@35up.com
victor)schroeder@35up.com
victor<schroeder@35up.com
victor>schroeder@35up.com
victor:schroeder@35up.com
victor schroeder@35up.com
victor\\schroeder@35up.com
victor"schroeder@35up.com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}