$re = '/^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$/im';
$str = '# Valid
victor.schroeder@35up.com
victor.schroeder+foo@35up.com
v_s@35up.com
1233@35up.com
victor.schroeder@xn--bcher-kva.de
# Invalid
victor.schroeder@35up
victor.schroeder@.35up.com
victor.schroeder@35up.com.
victor.schroeder@-35up.com
victor.schroeder@35up-.com
victor.schroeder@35up.com-
victor.schroeder@35up.-com
victor.schroeder.@35up.com
victor.schroeder@35up..com
.victor.schroeder@35up.com
victor.schroeder@35--up.com
victor.schroeder@xn---bcher-kva.de
victor.schroeder@35_up.com
# Blacklisted chars
victor;schroeder@35up.com
victor,schroeder@35up.com
victor@schroeder@35up.com
victor[schroeder@35up.com
victor]schroeder@35up.com
victor(schroeder@35up.com
victor)schroeder@35up.com
victor<schroeder@35up.com
victor>schroeder@35up.com
victor:schroeder@35up.com
victor schroeder@35up.com
victor\\schroeder@35up.com
victor"schroeder@35up.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);