#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$"
Local $sString = "# Valid" & @CRLF & _
"victor.schroeder@35up.com" & @CRLF & _
"victor.schroeder+foo@35up.com" & @CRLF & _
"v_s@35up.com" & @CRLF & _
"1233@35up.com" & @CRLF & _
"victor.schroeder@xn--bcher-kva.de" & @CRLF & _
"" & @CRLF & _
"# Invalid" & @CRLF & _
"victor.schroeder@35up" & @CRLF & _
"victor.schroeder@.35up.com" & @CRLF & _
"victor.schroeder@35up.com." & @CRLF & _
"victor.schroeder@-35up.com" & @CRLF & _
"victor.schroeder@35up-.com" & @CRLF & _
"victor.schroeder@35up.com-" & @CRLF & _
"victor.schroeder@35up.-com" & @CRLF & _
"victor.schroeder.@35up.com" & @CRLF & _
"victor.schroeder@35up..com" & @CRLF & _
".victor.schroeder@35up.com" & @CRLF & _
"victor.schroeder@35--up.com" & @CRLF & _
"victor.schroeder@xn---bcher-kva.de" & @CRLF & _
"victor.schroeder@35_up.com" & @CRLF & _
"" & @CRLF & _
"# Blacklisted chars" & @CRLF & _
"victor;schroeder@35up.com" & @CRLF & _
"victor,schroeder@35up.com" & @CRLF & _
"victor@schroeder@35up.com" & @CRLF & _
"victor[schroeder@35up.com" & @CRLF & _
"victor]schroeder@35up.com" & @CRLF & _
"victor(schroeder@35up.com" & @CRLF & _
"victor)schroeder@35up.com" & @CRLF & _
"victor<schroeder@35up.com" & @CRLF & _
"victor>schroeder@35up.com" & @CRLF & _
"victor:schroeder@35up.com" & @CRLF & _
"victor schroeder@35up.com" & @CRLF & _
"victor\schroeder@35up.com" & @CRLF & _
"victor"schroeder@35up.com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")