use strict;
my $str = '# Valid
victor.schroeder@35up.com
victor.schroeder+foo@35up.com
v_s@35up.com
1233@35up.com
victor.schroeder@xn--bcher-kva.de
# Invalid
victor.schroeder@35up
victor.schroeder@.35up.com
victor.schroeder@35up.com.
victor.schroeder@-35up.com
victor.schroeder@35up-.com
victor.schroeder@35up.com-
victor.schroeder@35up.-com
victor.schroeder.@35up.com
victor.schroeder@35up..com
.victor.schroeder@35up.com
victor.schroeder@35--up.com
victor.schroeder@xn---bcher-kva.de
victor.schroeder@35_up.com
# Blacklisted chars
victor;schroeder@35up.com
victor,schroeder@35up.com
victor@schroeder@35up.com
victor[schroeder@35up.com
victor]schroeder@35up.com
victor(schroeder@35up.com
victor)schroeder@35up.com
victor<schroeder@35up.com
victor>schroeder@35up.com
victor:schroeder@35up.com
victor schroeder@35up.com
victor\\schroeder@35up.com
victor"schroeder@35up.com';
my $regex = qr/^(?!\.)(?:\.?[\w\+]++)++@(?!\.)(?:\.?(?:xn--)?(?!-|.*--)[a-zA-Z0-9\-]++(?<!-)){2,}$/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}