re = /^\'(a|A)ctive(.*)(true|false)\;$/m
str = '\'active\' => true;
\'active\'=> true;
\'active\' =>true;
\'active\'=>true;
\'active\' => false;
\'active\'=> false;
\'active\' =>false;
\'active\'=>false;
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end