$re = '/^\'(a|A)ctive(.*)(true|false)\;$/m';
$str = '\'active\' => true;
\'active\'=> true;
\'active\' =>true;
\'active\'=>true;
\'active\' => false;
\'active\'=> false;
\'active\' =>false;
\'active\'=>false;
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);