package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\'(a|A)ctive(.*)(true|false)\;$`)
var str = `'active' => true;
'active'=> true;
'active' =>true;
'active'=>true;
'active' => false;
'active'=> false;
'active' =>false;
'active'=>false;
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}