#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\'(a|A)ctive(.*)(true|false)\;$"
Local $sString = "'active' => true;" & @CRLF & _
"'active'=> true;" & @CRLF & _
"'active' =>true;" & @CRLF & _
"'active'=>true;" & @CRLF & _
"'active' => false;" & @CRLF & _
"'active'=> false;" & @CRLF & _
"'active' =>false;" & @CRLF & _
"'active'=>false;" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")