using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\'(a|A)ctive(.*)(true|false)\;$";
string input = @"'active' => true;
'active'=> true;
'active' =>true;
'active'=>true;
'active' => false;
'active'=> false;
'active' =>false;
'active'=>false;
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}