import Foundation
let pattern = #"(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
403
123456
55324673 cups of tea and 1564 polar bears
ABC123131
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #","#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)