$re = '/(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))/';
$str = '403
123456
55324673 cups of tea and 1564 polar bears
ABC123131';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;