#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))"
Local $sString = "403" & @CRLF & _
"123456" & @CRLF & _
"55324673 cups of tea and 1564 polar bears" & @CRLF & _
"ABC123131"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)