re = /(?:\s|\G)\d+?\K(?=(?:\d{3})+(?!\S))/
str = '403
123456
55324673 cups of tea and 1564 polar bears
ABC123131'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result