import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|\\G)\\d+?\\K(?=(?:\\d{3})+(?!\\S))";
final String string = "403\n"
+ "123456\n"
+ "55324673 cups of tea and 1564 polar bears\n"
+ "ABC123131";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}