// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$").unwrap();
let string = "1.82.3-beta
master
21
12-hello-people
12-h3llo-people
1.12-alpha
1..2.3
1.2.3
alpha
beta
jklkkm
2-3-1-3
ew-234-sdads
2-h212332
2-212332
123-excellent
12-ExCelLenT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}