#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$"
Local $sString = "1.82.3-beta" & @CRLF & _
"master" & @CRLF & _
"21" & @CRLF & _
"12-hello-people" & @CRLF & _
"12-h3llo-people" & @CRLF & _
"1.12-alpha" & @CRLF & _
"1..2.3" & @CRLF & _
"1.2.3" & @CRLF & _
"alpha" & @CRLF & _
"beta" & @CRLF & _
"jklkkm" & @CRLF & _
"2-3-1-3" & @CRLF & _
"ew-234-sdads" & @CRLF & _
"2-h212332" & @CRLF & _
"2-212332" & @CRLF & _
"123-excellent" & @CRLF & _
"12-ExCelLenT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")