using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$";
string input = @"1.82.3-beta
master
21
12-hello-people
12-h3llo-people
1.12-alpha
1..2.3
1.2.3
alpha
beta
jklkkm
2-3-1-3
ew-234-sdads
2-h212332
2-212332
123-excellent
12-ExCelLenT";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}