$re = '/^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$/m';
$str = '1.82.3-beta
master
21
12-hello-people
12-h3llo-people
1.12-alpha
1..2.3
1.2.3
alpha
beta
jklkkm
2-3-1-3
ew-234-sdads
2-h212332
2-212332
123-excellent
12-ExCelLenT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);