package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^master$|^\d+(?:(?:\.\d+)+|(?:\-[A-z]+))+$`)
var str = `1.82.3-beta
master
21
12-hello-people
12-h3llo-people
1.12-alpha
1..2.3
1.2.3
alpha
beta
jklkkm
2-3-1-3
ew-234-sdads
2-h212332
2-212332
123-excellent
12-ExCelLenT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}