import Foundation
let pattern = #"^\+(?<PHONENUMBER>\d{8,15})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+12345678
+1234567
+123456
+12345
+16157725198
+16157725198
+111111111111111
+1111111111111111
+1111111111111111123123123123123213123
+1(801)8221439
+1(801) 822 1439
+1-801-822-1439
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)