#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\+(?<PHONENUMBER>\d{8,15})$"
Local $sString = "+12345678" & @CRLF & _
"+1234567" & @CRLF & _
"+123456" & @CRLF & _
"+12345" & @CRLF & _
"+16157725198 " & @CRLF & _
"+16157725198" & @CRLF & _
"+111111111111111" & @CRLF & _
"+1111111111111111" & @CRLF & _
"+1111111111111111123123123123123213123" & @CRLF & _
"+1(801)8221439" & @CRLF & _
"+1(801) 822 1439" & @CRLF & _
"+1-801-822-1439"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")