// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\+(?<PHONENUMBER>\d{8,15})$").unwrap();
let string = "+12345678
+1234567
+123456
+12345
+16157725198
+16157725198
+111111111111111
+1111111111111111
+1111111111111111123123123123123213123
+1(801)8221439
+1(801) 822 1439
+1-801-822-1439";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}