using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\+(?<PHONENUMBER>\d{8,15})$";
string input = @"+12345678
+1234567
+123456
+12345
+16157725198
+16157725198
+111111111111111
+1111111111111111
+1111111111111111123123123123123213123
+1(801)8221439
+1(801) 822 1439
+1-801-822-1439";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}