const regex = /^\+(?<PHONENUMBER>\d{8,15})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\+(?<PHONENUMBER>\\d{8,15})$', 'gm')
const str = `+12345678
+1234567
+123456
+12345
+16157725198
+16157725198
+111111111111111
+1111111111111111
+1111111111111111123123123123123213123
+1(801)8221439
+1(801) 822 1439
+1-801-822-1439`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}