$re = '/(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})/m';
$str = '010036838277501621307002621717551723063010O100050
010030054474225221100684537946921723083110AB5432B
01003005447422522110068453794692~1723083110AB5432B';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);