#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})"
Local $sString = "010036838277501621307002621717551723063010O100050" & @CRLF & _
"010030054474225221100684537946921723083110AB5432B" & @CRLF & _
"01003005447422522110068453794692~1723083110AB5432B"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")