package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})`)
var str = `010036838277501621307002621717551723063010O100050
010030054474225221100684537946921723083110AB5432B
01003005447422522110068453794692~1723083110AB5432B`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}