const regex = /(?:01(\d{14})|21([a-zA-Z0-9]{1,14})(\\x1d|~)?)|17(\d{6})|10([a-zA-Z0-9]{1,20})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:01(\\d{14})|21([a-zA-Z0-9]{1,14})(\\\\x1d|~)?)|17(\\d{6})|10([a-zA-Z0-9]{1,20})', 'gm')
const str = `010036838277501621307002621717551723063010O100050
010030054474225221100684537946921723083110AB5432B
01003005447422522110068453794692~1723083110AB5432B`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}