import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:01(\\d{14})|21([a-zA-Z0-9]{1,14})(\\\\x1d|~)?)|17(\\d{6})|10([a-zA-Z0-9]{1,20})";
final String string = "010036838277501621307002621717551723063010O100050\n"
+ "010030054474225221100684537946921723083110AB5432B\n"
+ "01003005447422522110068453794692~1723083110AB5432B";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}