import Foundation
let pattern = #"(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.1.1.1
10.10.10.10
255.255.255.255
1.255.1.123
0.1.1.1
1.0.0.0
1.1.1.1
255.256.255.255
127.0.0.1
.127.0.0.1
q.0.0.0
t.t.t.t
44.44.44.44
44.44.44.444
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)