// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$").unwrap();
let string = "1.1.1.1
10.10.10.10
255.255.255.255
1.255.1.123
0.1.1.1
1.0.0.0
1.1.1.1
255.256.255.255
127.0.0.1
.127.0.0.1
q.0.0.0
t.t.t.t
44.44.44.44
44.44.44.444
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}