import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^([1-9][\\d]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])\\.)(((0|[1-9][0-9]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])\\.){2})(0|[1-9][\\d]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])$";
final String string = "1.1.1.1\n"
+ "10.10.10.10\n"
+ "255.255.255.255\n"
+ "1.255.1.123\n"
+ "0.1.1.1\n"
+ "1.0.0.0\n"
+ "1.1.1.1\n"
+ "255.256.255.255\n"
+ "127.0.0.1\n"
+ ".127.0.0.1\n"
+ "q.0.0.0\n"
+ "t.t.t.t\n"
+ "44.44.44.44\n"
+ "44.44.44.444\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}