const regex = /(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^([1-9][\\d]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])\\.)(((0|[1-9][0-9]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])\\.){2})(0|[1-9][\\d]?|1[\\d]?[\\d]?|2[0-4][\\d]|25[0-5])$', 'gm')
const str = `1.1.1.1
10.10.10.10
255.255.255.255
1.255.1.123
0.1.1.1
1.0.0.0
1.1.1.1
255.256.255.255
127.0.0.1
.127.0.0.1
q.0.0.0
t.t.t.t
44.44.44.44
44.44.44.444
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}