re = /(^([1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.)(((0|[1-9][0-9]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])\.){2})(0|[1-9][\d]?|1[\d]?[\d]?|2[0-4][\d]|25[0-5])$/m
str = '1.1.1.1
10.10.10.10
255.255.255.255
1.255.1.123
0.1.1.1
1.0.0.0
1.1.1.1
255.256.255.255
127.0.0.1
.127.0.0.1
q.0.0.0
t.t.t.t
44.44.44.44
44.44.44.444
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end