// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[0]*([1][1][0|2|5])|([1][1][6]\d{3})|([1][1][8][1-9]{2})").unwrap();
let string = "110
112
115
19222
116117
116116
11800
11811
11823
118222
11899
1234
9987
1120
112554443";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}